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1.0 Introduction to BrowseControl

BrowseControl is an easy-to-use Internet management software that can readily be utilized by
non-technical users.

BrowseControl can totally deny access to the Internet. Or, you can allow access to specific company
or classroom sites through the Allowed List feature; all other sites will be restricted. Alternatively
users can be allowed access to all sites, except for those sites you list in the Blocked List. Users
can also be restricted access to e-mail, FTP sites, Instant Messaging, ICQ, Newsgroups, etc

In addition to restricting Internet activity, users can be denied access to unauthorized applications
such as MSN, Solitaire etc. This is achieved through the App Blocker feature.

This guide will help you better understand the features of the software and assist you in configuring
the tool according to your needs.

www.CurrentWare.com 4
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1.1 CurrentWare Components

There are four primary components in the CurrentWare Console

CurrentWare Server

This component includes a server Service and database. It houses all the data for the configuration
and settings. The CurrentWare Server is the central hub for the CurrentWare Consoles and the
CurrentWare Clients to connect to. A Firebird database is used for the data storage.

CurrentWare Console

This component is the management console that the administrator uses to control the functionalities
of the CurrentWare Solutions. The administrator will be able to see the connection status of their
CurrentWare Clients within the CurrentWare Console.

Multiple consoles can be installed on the same network. Multiple authentications can be assigned to
different users to allow or restrict the full functionality of the console.

Note: the CurrentWare Server and the Console components are commonly installed on the same
computer. Additional CurrentWare Consoles may be installed on other administrators’ computers.

CurrentWare Solutions

This component contains different functionalities based on the solution that you are installing. After
the installation of a CurrentWare solution, the solution’s functions will be embedded on the right
hand side of the CurrentWare Console.

e BrowseControl: Internet Management

e BrowseReporter: Internet Tracking and Reporting
e enPower Manager: Power Management

e AccessPatrol: Endpoint Security Solution

CurrentWare Client

This component is to be installed on all computers that need to be managed by the CurrentWare
Console. The CurrentWare Clients establish communication to the CurrentWare Server. The client is
password protected and runs in stealth mode.

www.CurrentWare.com 5
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1.2 System Requirements

Hardware Requirement

All components of the CurrentWare Console are supported on desktop computers and server
computers with the following specifications.

e Processor: any CPU running faster than Pentium I
e Memory: at least 128MB of RAM
e Disk Space: at least 100MB of disk space

Software Requirement
All components of the CurrentWare Console are compatible with the following Operating Systems
e Windows XP Professional*
e Windows Vista Professional*
e Windows 7 Professional and Ultimate*
e Windows Server 2003* and 2008**

* Support for 32-bit and 64-bit.

** Support Windows Terminal Server

www.CurrentWare.com 6
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1.3 Installing the CurrentWare Server, Console and
Solutions

Follow the instructions below to install the CurrentWare Server, Console and Solutions on your
network.

Before you begin your installation:

¢ Installation of all components must be done with an admin user account.
e The Server and Console components may be installed on the same computer.

1. Download the Setup Files
Download the CurrentWare setup files from our website:

http://www.CurrentWare.com. Remember to also download the setup file for

the CurrentWare solutions (BrowseControl, BrowseReporter,

enPowerManager and AccessPatrol) that you want to install.

2. Select a Computer to install the CurrentWare Server and Console

3. Install the CurrentWare Server and Console

1. Unzip the setup file that you downloaded from our website and run the
currentware.exe to initiate the CurrentWare Console Installation Wizard.

2. Proceed to accept the License Agreement.

3. Putin your User Information (Full Name and Organization name) and select
the software usage for “Anyone who uses this computer” or “Only for me”

4. Now, select the CurrentWare Components that you want to install. For first
time installation, click next. The install wizard will automatically select the
CurrentWare Console and Server to be installed on your computer.

5. Type in the computer name (or IP address) of your CurrentWare Server. For
first time installation, click next. The install wizard will automatically type in
your Computer name.

www.CurrentWare.com 7
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6. The Installer will now proceed to install the CurrentWare Server and Console
on your computer.

4. Install the CurrentWare Solutions
Once your CurrentWare Server and Console are installed, you can proceed to
install the CurrentWare Solutions by running the appropriate setup file below
(You have to download the CurrentWare Solutions setup file from our

website):

e BrowseControl: run BrowseControl.msi
e BrowseReporter: run BrowseReporter.msi
e enPowerManager: run enPowerManager.msi

e AccessPatrol: run AccessPatrol.msi

www.CurrentWare.com 8
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1.4 Installing the CurrentWare Clients

Follow the instructions below to install the CurrentWare clients on the computers you want to
manage. After a successful installation of the CurrentWare Clients, they will connect to your
CurrentWare Server and automatically show up on your CurrentWare Console.

Before you begin your installation:

o Installation of all components must be done with an admin user account.

e To successfully deploy the CurrentWare Client using the Remote Client Install utility,
please temporarily disable the Windows Firewall on the client computers and disable
Window’s Simple File Sharing.

There are four ways to deploy the CurrentWare Clients to your workstations.

1. Local CurrentWare Client Install: run the cwClient.msi file on all the
computers you want to manage.

2. Remote Client Install: use the built-in Remote Client Install tool on the
CurrentWare Console to push the CurrentWare Client install to the
computers.

3. Deploy the CurrentWare Client by Command Line: create a batch file
that will install the CurrentWare Client. Run the batch file through Active
Directory or Login Script.

4. Deploy the CurrentWare Client with a Third-Party Software Delivery

Tools: use third-party software to deploy the cwClient.msi file.

1.4.1 Local CurrentWare Client Install

This is the most standard method of installing the CurrentWare Client. Run the cwClient.msi file on
each computer you want to manage.

The cwClient.msi file can be found on the computer that you have installed the CurrentWare Server.
This set up file is stored under:

CurrentWare Client Setup File:
C:\Program Files\CurrentWare\cwClient\cwClient.msi

When you run the cwClient.msi on your managed computers, you will need to fill in the following
information.

www.CurrentWare.com 9
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1. Computer Name or IP Address of the CurrentWare Server
Put in the Computer Name or IP address of the CurrentWare Server that
you want the client to connect to. Ensure that the managed workstations

can establish connections to the CurrentWare Server.

2. CurrentWare Client Password (Optional)
The CurrentWare Client password is used to configure the CurrentWare
Client settings. If you do not put in a custom CurrentWare Client password,

then the default password is “Admin” (without the quote; case sensitive).

Upon the completion of your CurrentWare Client installation, it will automatically connect to your
CurrentWare Console.

1.4.2 Remote Client Install

Before you begin your installation:
e On computers running Windows Vista, Windows 7 and Windows 2008, please disable UAC
(User Account Control) before running the Remote Client Install.

CurrentWare Clients can be remotely installed from the Console. The remote installer can be found
on the console under the menu Install > Client > Remote Client Install.

1. Browse for the path of the CurrentWare Client setup file, cwClient.msi, on your
computer. By default this file is located in the following folder on the server
computer:

C:\Program Files\CurrentWare\cwClient\cwClient.msi

2. Select the option to enable or disable reboot after the installation (the
recommended option is to enable reboot).

Select the appropriate Install option: Fresh Install or Upgrade.
Enter the Computer name or IP address of the CurrentWare Server.

(Optional): Change the CurrentWare Client password.

© g &~ W

Select the computers you want to install the CurrentWare Client on:

www.CurrentWare.com 10
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a. You can enter the IP address manually, or

Click on the Search button to allow CurrentWare to look for the
computers on your network, or

c. Import from a text file that contains a list of your computers’ names of IP
addresses.

7. Enter the username and password of an account that has administrative rights
to the computers you are installing to

a. If you are a domain admin, put in the username in the format of
Domain\Administrator

8. The CurrentWare Client will now be deployed to the designated computers.

i

Remote Client Install

Helps to insta =rt =

D Remote Client Install

Enter the path of the Client msi file C:\Program Files\CurrentWareyowClientowClient. msi

Reboot dient systems after installation

RebootDelay: 0 5 minutes

@ Fresh Install ) Upgrade

CurrentWare Server (IP address or Computer name)

192,168.1. 100

[C] (optional): Change the CurrentWare Client Password
By default the dient password is "Admin”

Mew Password

Confirm Passwaord

Mext = ][ Cancel

The First screen of the Remote Client Install Window

1.4.3 Deploy CurrentWare Client by Command Line

The CurrentWare client file can be deployed through a single command line. Below is a list of
switches you can along with the command line to deploy the CurrentWare client with the
configurations of your choice.

www.CurrentWare.com 11



( G\) Current\X/are

e:\cwClient.msi ALLUSERS=1 USERPARAMS="-p Admin -ds
192.168.1.100 -rp test -sp test” /gn /I e:\install.log

Switches:

-p Required parameter (password is Admin)

-ds CurrentWare Server IP address or Computer name
-rp New Password (Optional)

-sp Confirm Password (Optional)
/gn Quiet Install
Nl Create a log file during the install. Specify the location and name of the log file.

In the above example, the network drive is assigned with the letter e:\. The CurrentWare
Client set up file is stored on the network drive and the install log file will be created on the
network drive after the installation.

1.4.4 Deploy CurrentWare Client with a Third-Party Software Delivery
Tool

The CurrentWare Client is packaged as a MSI file. You can use your company’s system deployment
tools to deploy the CurrentWare client to your workstations.

Deploy by customizing the cwClient.MSI file

You can take the existing cwClient.msi file and customize it with the proper CurrentWare Server
Computer name and other parameters before you deploy the file.

Use a MSI editor (for example, the Orca MSI editor) and modify the following table within the
cwClient.MSI file:

Table Property Value
Property USERPARAMS "-p Admin -ds 192.168.1.100"

Change the IP address in the value field to the IP address of your CurrentWare Server.

www.CurrentWare.com 12
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There are two ways to upgrade the CurrentWare clients in version 4 — Automatic upgrade or Manual

upgrade.

1.5.1 Automatic Upgrade of the CurrentWare Clients

The client upgrade process can be automated when you upgrade any version of the CurrentWare

client to the latest version.

On the CurrentWare Console, go to Install > Client > Remote Install

Click on the Upgrade button

Click on the “Automatically upgrade clients from version 4.0.0.0 and above”
checkbox and the CurrentWare Server will push the update to the clients.

Remote Client Install

E Remote Client Instal

Helps to install dient to a remote

Enter the path of the Client msi file

[ Reboot dient systems after installation
L8]

) Fresh Install

(Optional):

@ Upgrade (dients of version 4.0.0.0 and above)

Browse

Flease ensure that a previous version of
CurrentWare Client is already installed
on the destination computers,

Automatically upgrade dients from version 4.0.0.0

and above.

(The upgrade will occur once the dient connects to

the server).

The Client upgrade is automatic when this option is enabled.

1.5.1 Manual Upgrade of the CurrentWare Clients

The client upgrade method can be done manually by running the cwClient.msi file on each computer

that has CurrentWare v4 client installed.

www.CurrentWare.com
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1.6 Terminal Server Setup

The CurrentWare Console is compatible with Windows Terminal Server. The terminal server
installation is the same as a normal CurrentWare Console installation.

The following Solutions are compatible with Terminal Server:

e BrowseControl

e BrowseReporter

1.61 BrowseControl and Terminal Server

In order to view the users on your Terminal Server, you must change your CurrentWare Console
from PC mode to User mode.

On the CurrentWare Console, expand the BrowseControl tab on the right hand side. Click on the
Mode button. Select User mode and click Apply. You are now using BrowseControl in User Mode.

Once you are in user mode, your Terminal Server users will be listed under the User Mode tab
automatically after they log onto the terminal server for the first time.

1.62 BrowseReporter and Terminal Server

BrowseReporter is automatically compatible with Terminal Server without the need of any further
configurations.

The Terminal Server users will be listed under the User Mode tab automatically after they log onto
the terminal server for the first time.

www.CurrentWare.com 14
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2.0 CurrentWare Console Overview

The CurrentWare Console is the manager that the administrators will use to control the managed
workstations.

The CurrentWare Console contains the following functions.

e Client and Group Management
e Redirect Clients

e Client Settings

e Operators

e Import Users

e Options

e Log Out

‘G CurrentWare o[RS
File View Tools Instal Help
z ® ISl
"PCMode | UserMode Products |
5e Computers Computer 1P Address Status 43  AccessPatrol ™ |

=-{C3) Accounting

A Clarissa Blodeuwedd
2-{3) Management
A Wendell Josse
& sara Minty
B+ Marketing
I Oona Rhianon
=+{C3) Operations
I/ Sue Elizabeth
=143 Sales
I Ariana Leona
I/ Kaelee Carina
I Carreen Evonne
‘,_u Benjamin Kip
I Trace Mack

K Baxter Grady K Ariana Leona 192.168.1.101 Active user(s): Ariana
i& Benson Gene I Kaelee Carina 192.168.1.102 Active user(s): Kaelee | «J BrowseControl Fj |
I Henrietta Brandi K Carreen Evonne 192.168.1.103 Active user(s): Carreen

F-0 F‘If:ance I/ Benjamin Kip 192.168.1.104 Active user(s): Benjamin (== L m J
‘; yv:;?dEBvr:Imen l__- Trace Mack 192.168.1.105 Active user(s): Trace " Fj

K 15 Connected

W ot Connected

Ver. 4.1.0.0

BrowseControl

The CurrentWare Console

No. of Licenses: 15

Used Licenses: 15

www.CurrentWare.com
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2.1 Client and Group Management

In computer mode, a connected client is represented by a blue computer icon, while an unconnected
client is represented by a grey computer icon. In user mode, an active user is represented by a
green user icon, while an inactive user is represented by an orange user icon. For ease of
management, the workstations and users can be organized into groups.

Create a New Group

To create a new group, from the menu, select File > Add New Group.

Or, right click on the computer pane in the CurrentWare console and select Add New
Group.

Rename a Group

To rename a group, from the menu, select File > Rename

Or, right click on the computer pane in the CurrentWare console and select Rename.

Delete a Group

To delete a group, from the menu, select File > Delete

Or, right click on the computer pane in the CurrentWare console and select Delete.

Move Computers/Users

On the CurrentWare Console, organization of the computers, users and groups can be
accomplished by dragging and dropping the selected computer/user into the group. To
facilitate the organization of a large number of computers, users or groups, you can use the
Move Computers/Users function.

On the CurrentWare Console menu, select File > Move Computer/Users. The left hand
side contains the source folder and the right hand side contains the destination folder. Select
the computer(s) you want to move from the source folder, and then select the destination
folder. Click on the >> button to move the computers.

www.CurrentWare.com 16
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Redirect Clients is usually used when there are more than one CurrentWare Servers installed on
your network. It is used to connect the CurrentWare Clients from another CurrentWare Server to the
current CurrentWare server. Essentially, the redirect clients tool, transfers the CurrentWare Clients
from one server to another.

Scenario: | need to transfer all of my CurrentWare Clients from my old server to the new server.

© g &~ w D

Select Redirect All CurrentWare Clients.

Enable the option Redirect connected Client(s)
Click on OK

After a brief moment, the CurrentWare Clients will start connecting to the
new Server.

On the new CurrentWare Server, launch the CurrentWare Console and
access the menu Tools > Redirect Clients.

Enter the CurrentWare Client password. The default password is Admin

@ Redirect Clients

|

s Bediregt Clients :

entware Clients to the current ser

Server Name SEVEN-PC

Client Password

@ Redirect All CurrentWare Clients

) Redirect Specific CurrentWare Clients

Computers IP Address Domain/Workagroup
Select all computers
| Redirect connected dients [ oK ] ! Cancel ]

Redirect CurrentWare Clients that are connected to one CurrentWare Server

to another CurrentWare Server

www.CurrentWare.com
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The CurrentWare Client settings can be modified in the CurrentWare Console under Tools > Client

Settings. You can also right click on a group to find the Client Settings.

Change Password

Put in the new CurrentWare Client password to replace the existing CurrentWare Client password.
You will need to use the CurrentWare client password if you want to change the client settings, such
as IP address or computer name of the CurrentWare Server or the port that the client use to connect
to the CurrentWare Server. By default the case sensitive Client password is Admin.

Options

e Run at Windows Startup: toggle the option to allow the CurrentWare client service to start
every time the workstation boots up.

e Show in System Tray: toggle the option to display the CurrentWare icon in the system tray.
When this option is enabled, the administrator can double click on the icon, put in the

password, to access the CurrentWare Client configuration window.

e Block admin users from stopping the client: toggle the option to prevent the users of the
workstation to stop the CurrentWare Client service or end the CurrentWare Client process.

Ok

Client Settings

-

=

E Client Settings

Client password/settings can be changed from her

Client Settings for Group: Computers

Chanaose Passwaord

Mew Password

Confirm Password

Lphons

Run at windows startup
[] show in system tray

Blodk admin users from stopping the dient

oK Cancel

J

J

Apply

CurrentWare Client Settings

www.CurrentWare.com
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2.4 Operators

Operators are used in the CurrentWare Console to assign console permissions to different users.
The Operators utility is available on the CurrentWare Console under Tools > Operators. There are
two types of operators in CurrentWare Console: Administrator and User.

Administrator type has complete control over every computer, group and the solution’s
functionalities.

User type has limitations defined by the administrator. These limitations include the
solution’s functionalities and group accesses.

Password Protect the Console

In order to password protect the console, operator accounts need to be created.

Creating an Operator:

1.

o K~ WD

Launch the CurrentWare Console.

On the menu select Tools > Operators.
Click on the Add button.

Fill in the name, password and description.

Select a role for this operator. While the Administrator role has access to all
the features of BrowseReporter, the User role only has the limited access to the
solution’s functionalities.

Click OK to create a new operator.

Enable Password Protected CurrentWare Console

BowN

Create an operator with the step above.
Check the option Enable Password Security.
Log out of the CurrentWare Console.

The next time you log into the CurrentWare Console, you will be prompted for a
username and password.
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Operataor Description

& administrator

["] Enable Password Security Operator Bermissions = B
THE R Rale
Operator Manager i) Administrator @ User
Password FEm——

Confirm Passward

Description Manager account with limited functionalities Add Operator

[l
=]

Administrators have unlimited control. Users have limited controls

2.5 Import Users

The Import users function will import your existing Windows users from your Active Directory domain
into the CurrentWare Console.

1. In order to import users, your CurrentWare Console must be in User Mode. Click
on the tab called “User Mode” below the toolbar on the left hand side to activate
User Mode.

Click on Tools > Import Users
Select to Import from Active Directory or from a Text File

Enter the Domain administrator credential (Domain name, user name and
password) and click on the Import Users button.

A list of your Active Directory Users will be populated in the window.

Select specific users you want to add to the CurrentWare Console or click on
the checkbox Select All Users.

7. Click Add Users to add the selected users to the Console.
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-

‘O Import Users @

&3 Import Users

POrt Users

Impu:-rt users from @ Active directory () Text file

Niomiain [

tails

Damain Mame

User Mame Password Import Users

Trnart | lesrs

Active Directory Users

Select All Users

Import Windows Users from Active Directory

NOTE: When you import users from Active Directory to the CurrentWare Console as
operators, the operator name will be the same as the username on active directory.
However, the passwords cannot be retrieved directly from the Microsoft Active
Directory for security purposes. The new password for each operator is the username
in lowercases. For example, if your Active Directory username is John, your
CurrentWare operator password will be john.

2.6 Options

Details of the Console port and newly connected client management are available on the
CurrentWare Console under Tools > Options
General

Add new Computers to the group: define the group that a new computer will automatically be
assigned to once it connects to the CurrentWare Server for the first time.
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Add new Users to the group: define the group that a new user will automatically be assigned to
once it is populated to the CurrentWare Server for the first time.

‘@) Options @
& & Options
Mewly connected dient computers will be added a atica e belo
" General Connection
Add new COMPUTERS to the group: ’Cumputers[Rth] v]
Add new USERS to the group: ’Users [Roat] v]
QK ] [ Cancel ] Apply

Connection

CurrentWare Server: the computer name or the IP address of the CurrentWare Server that the

CurrentWare Console is connected to.

Console Port: The port that CurrentWare Console uses to connect to the CurrentWare Server. The

default Console port is 8990.

‘@) Options @
Q Options
Connection to CurrentWare Server can be set here
General Connection
CurrentWare Server (CODEWORK
Console Port 3990
QK ] [ Cancel ] [ Apply ]
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2.7 Log Out

Log Out can be used to re-log into the Console with a different user name and password. This
feature can be found under the menu File 2 Logout.
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3.0 Overview of BrowseControl Functions

BrowseControl is an Internet restriction tool that allows an administrator to control the Internet
access of your users.

An overview of the BrowseControl functions includes:

e Controlling the Internet

e URL Filtering

e Blocking Users from Downloading Files
e Bypass Applications

e Application Blocker

e Port and Proxy Settings

@l BrowseControl =

o Internet
% Internet Scheduler

@ Timer

& Internet Quota Limit

) URL Filter
% Download Filter
= Bypass Application

0 Display Warning Message

. App Blocker
= App Blodker Scheduler

£ Block Ports
S Copy Group Settings

Q Apply Internet Settings to Clients
te) Clear Internet Settings

k&3 BrowseControl Client Settings

#. Mode

ﬂ Help

BrowseControl Solution Features
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4.0 Controlling the Internet Access

BrowseControl provides three different methods for controlling a client’s Internet access.

e Internet ON/OFF
e Scheduler

e Timer

All three settings can be applied at a group level. The Internet ON/OFF feature and the Timer can
also be applied to an individual computer/user.

4.1 Turning the Internet ON/OFF

The BrowseControl Console allows for direct control of Internet access privileges for a group of
clients or an individual computer/user.

If Internet is set to ON, clients will have complete access to the Internet. (The Blocked list
will be activated, see URL filtering for more details)

If Internet is set to OFF, access to any Internet websites will be denied. (The Allowed list
will be activated, see URL filtering for more details)

To force the Internet policy to all clients in a group, select the group on the left hand tree of the
Console. Under the BrowseControl tab on the right hand side of the CurrentWare Console, click on
Internet and select on or off.

In the CurrentWare console, groups do not inherit settings from their parent groups. The groups
stores the CurrentWare settings independently.

The Client settings get priority over its Group settings. For example, if the Internet setting for a
Group is set to OFF, you can temporarily override this setting for a specific computer or user and set
the Internet to ON for that computer or user. The Client settings will take priority over the Group
settings.

@l BrowseControl =
v| on |+ Internet |
OFF |~.". Internet Scheduler
fu Timer
€3 URL Filter

% Download Filter
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4.2 Internet Scheduler

Schedules can be created to allow Internet access at specific times. This is a Group specific
setting. Groups can be assigned to three levels of Internet accesses:

1.

2.

Internet ON: Full access to the Internet and deny access to the URLSs listed in the Blocked
list.

Custom Allowed List: Allow access to specific websites. For example, during lunch time
you may want to allow users access to additional websites such as facebook.com and
myspace.com. This can be achieved by specifying the URLs in the “Custom Allowed URLs”
option. When “Custom Allowed URLs” is activated, users can access websites from the
“Custom Allowed URLSs” list and the global Allowed list from the “URL Filter”. Upon reaching
the scheduled end time, the user will only be allowed to browse the authorized websites from
the URL Filter's Allowed list.

Custom Blocked List: Deny access to unauthorized sites. Users will be denied access to
websites listed in the Custom Blocked list during the scheduled time.

Creating an Internet Schedule

1.

Highlight the group you want to assign a scheduler to and select Internet
Scheduler under the BrowseControl tab on the right hand side of the
CurrentWare Console.

Click on the Add button to create a new schedule.
Select the Schedule Start and Stop Times
Select the Schedule type:

e Internet ON: for full Internet access. But the websites listed in the
original Blocked list will still be denied.

e Custom Allowed List ON: Internet access restricted to websites listed in
the Custom Allowed List plus the websites on the original Allowed List.

e Custom Blocked List ON: Internet access to websites on the Custom
Blocked List will be denied.

5. Select the Schedule Frequency: Daily, Weekly or Monthly
6. Click on the Add Schedule button to create the Internet Schedule.

e If a schedule type of Custom Allowed List was selected, then click on
the Custom Allowed List hyperlink listed under the Schedule Type column
to add the authorized URLs.

e |If a schedule type of Custom Blocked List was selected, then click on
the Custom Blocked List hyperlink listed under the Schedule Type column
to add the restricted URLSs.
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e Up to 50 URLs can be added to the Custom Allowed List or the Custom
Blocked List.

e Up to 20 different Internet schedules can be set per Group.

7. Click on Enable Scheduler
8. Click on Apply to Clients

@' Scheduler @
£ @ Scheduler
e Daily, Weekly and Monthly Schedules
Schedule for Group: Computers
Schedule Start Time Stop Time Days/Months Schedule Type
Weekly 1:00 FM 2:00 FM Man Tue Wed Thu Fri Internet ON
Weekly 5:00 PM F:00 PM Man Tue Wed Thu Fri Internet OM
Add Edit Remove
Schedule Time StartTime | 5:00 FM 5 Stop Time | 7:00 PM 5
Schedule Type @ Internet ON ) Custom Allowed List ) Custom Blocked List
Scheduls Frequency [Weekly' "']
eekly
Monday Tuesday Wednesday Thursday Friday [F] saturday [F]sunday

( Add Schedule |

[ Disable Scheduler ] [ Clear ] [ 0K ] [ Cancel ] [ Apply To Clients ]

(=]

The Internet Scheduler sets the time for the Internet access to go on and off
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Internet Scheduler Scenarios

Companies enforce different Internet policies during different times of the day. Below are a few
examples that you can use to set up the Internet scheduler suitable for your network.

Internet ON

If you selected Internet On, then the PC/user will have full Internet access until the stop time is
reached. The period during the stop time and the next start time, the Internet will be set to off. The
original Allowed list and Blocked list from the URL filter is still active.

Internet ON example:
e Internet ON during lunch time (1:00 P.M. to 2:00 P.M.)

(& cheduter ==
(© Scheduler

DaysMoontns Schedule Type

Intarmet O

Enabie Scheduler Ceear oK Cance

The Internet is set to ON during lunch. All other times, the Internet is OFF.

Custom Allowed List

If you selected Custom Allowed list, then the PC/user will have access to the original Allowed list
and, on top of that, they will have access to the websites you defined on the Custom Allowed list
(Internet scheduler) during the defined time period.

Custom Allowed List example:
e During standard hours (before 1:00 P.M. and after 2:00 P.M.), the user will have access
to the websites on the original Allowed list.
e During lunch hours (1:01 P.M. to 2:00 P.M.), the user will have access to the websites on
the original Allowed list and the websites on the Custom Allowed list.

J Scheduter

=

Scheduler
& :
—

Dsadle Scheduler

Cear

o

Schedule Type

Cancel

Custom Allowed list is used during lunch hour to add additional websites to the Allowed list
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Custom Blocked List

If you selected Custom Blocked list, then the PC/user will not have access to the websites on the
custom blocked list during the defined time period.

Custom Blocked List example:
e During standard hours (9:00 A.M. to 1:00 P.M. and 2:01 P.M. to 5:00 P.M.), the user will
not have access to the websites from the original Blocked list under the URL filter
e During lunch hours (1:01 P.M. to 2:00 P.M.), the user will have not have access to the
websites from the Custom Blocked list under the Internet scheduler.

(G scheduter ==

& ule
3

Sheduie Strt Time Stop Teve Says Momtns Schedule Type

Intarmet ON

Add

Enablie Scheduler Ceear oK Cancel

The user's websites are restricted by two different Blocked lists at different times: the original Blocked list is active
during office hours and the Custom blocked list is active during lunch hours.

4.3 Timer

The Timer feature allows you to assign Internet ON or OFF permissions on an ad hoc basis. For
example, if a Client PC/User is set to Internet ON at a specific time and you would like to temporarily
block their Internet access, the Timer feature will allow you to set Internet to OFF for a specific
amount of time. Once the timer has expired, the Internet settings will return to the previous Internet
mode (ON/OFF or Schedule). The timer can be set for a whole group or an individual client.

1. To enable the Timer, highlight the group that you want to set the timer to and
select Timer under the BrowseControl tab on the right hand side of the
CurrentWare Console.

2. The Timer screen will be displayed.

3. If the Internet status is ON then BrowseControl will automatically choose OFF
Timer or vice versa

4. Set the timer period.
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5. The format of the timer is HH:MM

You can only use the Scheduler or the Timer one at a time. When in use, the timer will temporarily

override the Scheduler settings. Once the timer has expired, the Scheduler will regain of the Internet
settings for that group/client.

@'Timer @
. % Timer
Group: Computers
@ ON timer
OFF timer Timer period 00:00 = (hh:mm})
[ Ok ] [ Cancel Apply

The Timer will temporary allow Internet access to the user for a predefined period of time.

4.4 Internet Quota Limit

With the Internet Quota Limit, the administrator can control how often users have access to the
Internet on a daily basis. The Internet Quota limit is defined by the administrator and will start
counting down as soon as the quota is enabled. The users will get notification messages on their
computers about how much remaining time they have for their Internet quota.

&' Internet Quota Limit @
@ Internet Quota Limit
== Set a daily quota limit for the Internet usage.

Group: Computers

Advanced Quota Options

Quota 02 Vl hr{s) [15 Vl min{s)

Enable Quota [ Disable Quota ] [ Close ]

Limit the Internet browsing time of your users by setting an Internet Quota Limit.
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Advanced quota options allow you to configure the Internet quota limit with default session period,
guota limit message and the notification period.

&' Advanced Quota Options

4@ Advanced Quota Options
Group: Computers

Default Session Period |1 | min(s)

Quota Limit Message Your Internet quota limit has been reached.

Motify every | 10 ~ | min{s) about the remaining quota time

Help [ O ] I Cancel Apply

Default Session Period: Each time a user’'s computer accesses the Internet,

BrowseControl records the activity as a default session. The default session is a

measurement that is used to accumulate the Internet Quota Limit. Any other

activities during the default session period will not be added to the Internet quota.

By default, the default session period is set to 1 minute.

Quota Limit Message: A custom message to notify the user that the Internet

Quota Limit has been reached.

Notification Period: An alert message that appears in the system tray to notify

the user of their remaining Internet quota. The administrator can define how often

the alert message will be shown on the user’'s computer.
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5.0 URL Filter

Under URL Filter, you can define your URL Allowed List or Blocked List. With the URL Filter, you
can customize specific websites that your users are allowed or not allowed to go to.

The Allowed List and Blocked List are activated based on the Internet settings that you have
selected. The scenarios below show when the Allowed List or the Blocked List is activated.

If Internet is OFF, Allowed List is activated. The users will only be able to

access the websites that are on the Allowed List.

If Internet is ON, Blocked List is activated. The users will be able to access all

the websites except for the websites that are on the Blocked List.

5.1 Allowed List

BrowseControl has the functionality to allow access to certain web sites when the Internet
connection has been turned OFF. This feature, referred to as the Allowed List, is available to Groups
only. That is, the Allowed List is Group specific and cannot be applied to individual computers or
users. Since this functionality is group specific, you can have certain URLs available to Clients within
one group and deny access to Clients in other groups. Outlined below are the steps for applying the
Allowed List.

How to Create an Allowed list for your group

1. Select the group for which you want to create the Allowed list for.

2. Under the BrowseControl tab on the right hand side of the CurrentWare
Console, click on Internet and select OFF. This will disable their Internet
access completely.

Under the BrowseControl tab, click on URL Filter to modify your Allowed list

Enter the URLs that you want to allow in the text box on the bottom left hand
corner of the window. Click on the Add button.

NOTE: When entering URL addresses, do not enter http:// before your
website. The http:// prefix will cause BrowseControl to ignore that website
altogether and the website will not be allowed in this scenario if it has the http://
prefix.

For example, if you would like to give access to http://www.currentware.com, on
the Allowed list, put in www.currentware.com without the http://. To give access
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to the entire domain of www.currentware.com, simply add currentware to the
Allowed List.

Click the “Allowed list” tab on the right pane.
Select all the URLs you wish to make available to the Client computers,

7. Click on the button to move the entries to the Allowed List on the right
pane

8. Click Apply to Clients

(' URL Filter =

Q URL Filter
- URL Filter allows access to URLs in the Allowed List and denies access to URLs in the Blocked List

Group: Computers

" URL List Allowed List | BlockedList | Enable URL Filter
URL URL

'@' www, browsecontral, com
'@ v, codewark, com
'@' wWww, currentware, com

A W
M W

Enter URL

add ] [Remove

| copyurLFiter || ok || ApplytoCients |

]

Users will have access to the websites on the Allowed List
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5.2 Blocked List

BrowseControl has the functionality to prevent access to certain web sites when the Internet
connection has been turned ON. This feature, referred to as the Blocked List, is available to Groups
only. That is, the Blocked List is Group specific and cannot be applied to an individual computer or
user.

How to Create a Blocked list for your group

1. Select the group for which you want to create the Blocked list for.

2. Under the BrowseControl tab on the right hand side of the CurrentWare
Console, click on Internet and select ON.

Under the BrowseControl tab, click on URL Filter to modify your Blocked list

Enter the URLs that you want to block in the text box on the bottom left hand
corner of the window. Click on the Add button

NOTE: When entering URL addresses, do not enter http:// before your
website. The http:// prefix will cause BrowseControl to ignore that website
altogether and the website will not be blocked in this scenario if it has the http://
prefix.

For example, if you would like to block access to http://www.facebook.com, on
the Allowed list, put in www.facebook.com without the http://. To block access
to the entire domain of www.facebook.com, simply add facebook to the Blocked
List

Click the “Blocked list” tab on the right pane.

Select all the URLs you wish to deny access to for the Client computers,

7. Click on the button to move the entries to the Blocked List on the right
pane

8. Click Apply to Clients
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@l URL Filter
™ URL Filter

URL Filter allows access to URLs in the Allowed List and denies access to URLs in the Blocked List

Group: Cc-mputers|

" URL List AllowedList "~ Blocked List | Enable URL Filter
URL URL
@ wwww, facebook.com
@ WYL MYSPace, com
Q www, twitter. com
@ www. youtube, com
Enter URL
P
Help [ copyURLFiter || oK ] [ Apply to Clients

Users will not have access to the websites on the Blocked List

5.3 Importing URLSs to the Allowed List or Blocked List by
text file

Under the BrowseControl tab, click on URL Filter

Click on the List (Allowed List or Blocked List) that you want to import the URLs
to.

3. Click on the Import button and browse to the text file that contains your URLSs.
Within the text file you are able to import, each URL should be listed on a new
line

4. Click Apply to Clients
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5.4 Exporting URLs from the Allowed List or Blocked List
by text file

Under the BrowseControl tab, click on URL Filter

2. Click on the List (Allowed List or Blocked List) that you want to export the URLs
to.

3. Click on the Export button and browse to the text file that contains your URLSs.
Within the text file you are able to import, each URL should be listed on a new
line

4. Click Apply to Clients
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6.0 Download Filter

The Download Filter is a list of file extensions that the administrator can allow or deny the users from
accessing while they are surfing the Internet.

By default, the Download Filter contains the categories of images and layouts. The reason for this is
that some websites retrieve image files and layout files from external websites or servers. In order
for the website to look properly, the Download Filter will allow the images and layout files on the
website to be loaded without being blocked even though the files are not on the Allowed list.

In contrast, you can put files extension on the Download Filter that may be a threat to your network.
By adding .exe, .zip, .tar and etc. files on the Download Filter, you are preventing users from
downloading those files.

The streaming of audio and video files can also be blocked by putting in the appropriate file
extension, such as .mp3, .swf and .mpeg.

There are three permission types. When “Allowed” is selected, the file extensions in the category will
be allowed. When “Blocked” is selected, the file extensions in the category will be blocked. When
“None” is selected, the file extensions in the category are not active and will be ignored.

’@' Download Filter @

# Download Filter

‘ Enable/Disable the downloading of files

-

Category Mame

Category File Types  Permission
Layouts Add Allowed -
Help Remoye ] [ oK ] [ Cancel ] [ Apply

Download filter will prevent specific file extensions from running on the user's Internet browser
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How to add a Download Filter

1. Under the BrowseControl tab on the right hand side of the CurrentWare
console, select Download Filter

2. In the Category Name text box, add a name for the Download Filter and click on
the Add button.

3. Click on the Add link under the File Type column for the category that you just
created

A new window will open
Add the file extensions that you want to Allow or Block.
After your file extensions have been added to the list, click Ok.

No g A

In this window, under the permission column, select Allowed or Blocked to
define the permission you want to set for the category that you just created.

For your reference, below is a list of common audio and video file extensions.

Common Audio File Extensions Common Video File Extensions
aac Advanced Audio Coding .392 3GPP2 Multimedia File
' File
.3gp 3GPP Multimedia File

aif Audio Interchange File

Format Advanced Systems Format
== File
Aff Interchange File Format
.asx Microsoft ASF Redirector File
.mp3 MP3 Audio File
.avi Audio Video Interleave File
.mpa MPEG-2 Audio File
flv Flash Video File
ra Real Audio File
.mov Apple QuickTime Movie
.wav WAVE Audio File
.mp4 MPEG-4 Video File
wma Windows Media Audio File
.mpg MPEG Video File
.rm Real Media File
.swf Flash Movie
.vob DVD Video Object File
wmv Windows Media Video File
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When BrowseControl is activated, it monitors the incoming and outgoing traffic from HTTP (port 80).
Most of the time, only Internet browsers use port 80 to display websites. However, some networks
have software that may use port 80 to transmit packets over the network. For example, some
software needs to retrieve update information through port 80. For this type of a situation, you need
to add the software that is using port 80 to BrowseControl’'s Bypass Application List.

Applications added to this list will be unaffected by BrowseControl’s Internet ON/OFF settings. This
is useful for legitimate applications that require access over HTTP. They can be added as follows:

1. Under the BrowseControl tab, click on Bypass Application.

2. Under the “Application List,” enter the Original Filename of the application to be

bypassed, in the “Application Name” textbox.

3. Alternatively, click on the Browse button and locate the .exe file of the
application to be bypassed. The Original Filename of the application will
automatically be populated in the list. In case the application does not have an
Original Filename the application will automatically populate the Application list
with the File’s Checksum value.

’iﬂ' Bypass Application

=

TN g Ea—
roup: Lomputers

Application Mame/Checksum

% Bypass Application

Description

Browse

Application

Description

Ok

] [ Cancel

]

Add applications to the Bypass list to allow complete network access for the defined applications
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8.0 Display Warning Message

The alert received by the users when accessing unauthorized websites can be customized in the
Display Warning Message option.

The URL Message is fully customizable. There are five different methods to display the warning
message.

e Display in Browser: The warning message is displayed directly on the
Internet browser on the user’s current page.

e Pop-up Window: A pop-up window in web form will appear every time a
user is accessing an unauthorized URL.

e Message Box: A Windows message box will display an alert for every
URL that is denied.

e Display Web Page: The user will be redirected to a special website
defined by the administrator

e None: The user will receive the generic Windows error for when a website

IS not available.

'll-ﬂ' Dizplay Warning Messages @
o Display Warning Messages

@) Display in Browser Your IT Administrator has prevented you from browsing
) Pop-up Window this URL.

) Message Box

" Display YWeb Page
) Mone

I Ok I [ Cancel Apply

Customize the alert message displayed on the users' screen when they accessing an unauthorized website
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9.0 Application Blocker

The Application Blocker prevents users from launching unauthorized programs on their computers.

This feature is Group specific. As a result you can block certain applications to computers and users
within one group, and specify a different blocked list for other groups

How to block your users from launching an unauthorized application

1. Select the group for which you want to apply the App Blocker.
Under the BrowseControl tab, click on the App Blocker option

Before an application can be blocked, it must be added to the Application List.
Enter the Original Filename of the application to be blocked in the Application
Name textbox. A description can also be entered for convenience.

NOTE: To manually locate the Original Filename of an application, right click
on the exe file in Windows Explorer and select Properties. Select the Version
tab and click on Original Filename in the Item Name box. The original filename
is located in the adjacent Value box. The figure below gives an example for
locating the Original Filename of Spider. Not all Original File names have the
.exe suffix extension. e.g. FreeCell has no extension so just enter “FreeCell”.

4. Alternatively, click on the Browse button and :p-:i-dnr.cm Proparlios

locate the .exe file of the application to be . =
blocked. The Original Filename of the fGorwral| Verion | Compaibiiy] Secip) Sy
application will automatically be populated in Fila versior: 5.1 2600 2180
the Application List. In case the application i _
does not have an Original Filename the i
application will automatically populate the Coppightt @ Miziasolt Coeporation. Allnights reserved,
Application list with the File’s checksum.
Dkt wersion infoimation
_[I:rnng.rnc' g Wahe
5. To add applications to the App Blocker list, e o
select the applications to be blocked from e e
the list of applications on the left pane and
move them to the right pane by clicking on Kyt
>> putton. These applications will now be
blocked for the computers and users under
the specific Group. The App Blocker list can
accommodate up to 200 applications.
[ ok J[ Concel |
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@' App Blocker @

Dl

enies arcess ta Hhe anolications so =d in the Elo A . -t AN . I r A

Application List Blocked Application List Enable App Blocker
Application Description Application Description

4703336 ‘fahoo Messenger

freecel Freecell

mshearts.exe The Microsoft Hearts Network

spider Spider

A v
A v

Application Mame fChecksum Description

Browse Add Remaove Import Export

He [ YWarning Message ] [ App Blocker Scheduler ] [ QK ] [ Cancel ]| apply

The Application Blocker prevents programs from launching on the users' workstations

9.1 Application Blocker Scheduler

Schedules can be created to allow access to the blocked applications at specific times. This is a
Group specific setting. To assign a schedule:

Select the group that you want to apply the Application Blocker Scheduler to.
Under the BrowseControl tab, click on the App Blocker Scheduler
Click on the Add button

Choose the start time and the end time for your App Blocker schedule. The
schedule time will allow the application to run during within the chosen period.
The application will be denied from launching outside of the scheduled time.

BN e

Choose the Schedule frequency of daily, weekly or monthly.

Click on the Add Schedule button to add the defined time schedule.
Click on the Enable Scheduler button.

Click on Apply to Clients.

© ® N o o

Up to 20 schedules can be set per group.
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At the scheduled time, the users will be able to access the blocked applications. Access to the
blocked applications will be terminated immediately, when the stop time is reached.

9.2 App Blocker Warning Message

When a user tries to launch a blocked application, a customized message can be presented to notify
the user that access is denied for this application.

1. The message can be changed by clicking on the Warning Message button in the
App Blocker Window.

Enter your message in the App Blocker Message textbox
3. Click on the Apply button to save the message.

9.3 Importing Applications to the Blocked Application List
by text file

Under the BrowseControl tab, click on App Blocker

Click on the Import button and browse to the text file that contains your
applications. Within the text file you are able to import, each applications should
be listed on a new line

3. Click Apply to Clients

9.4 Exporting Applications from the Blocked Application
List by text file

1. Under the BrowseControl tab, click on App Blocker

Click on the Export button and browse to the text file that contains your
applications. Within the text file you are able to import, each applications should
be listed on a new line

3. Click Apply to Clients
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10.0 Block Ports

BrowseControl has the ability to control ports. The administrator can disable the access to specific
ports by adding them to the Block Ports list.

There are three options in the Block Port list:

e Port Number: this is the port number that the computers on your network

use to communicate with other computers or over the Internet.

e Port Type: this is a description field that allows you to add a name or an

alias to the port number that you are adding.

e Filter Type: there are two filter types in the Block Ports list. The “‘HTTP”
filter is used to control the Internet. It is primarily used for HTTP, HTTPS
and the Proxy environment. The “Blocked” type will completely block all

incoming and outgoing traffic from the defined port.

To filter HTTPs site: add port number 443, port type HTTPS and filter type as HTTP filter to the list.

For organizations with a Proxy Server: the company’s proxy server port must be added to the
Block ports list with the Filter type set to HTTP Filter. This is required in order for BrowseControl to
control the Internet activities of your computers.

@ Block Ports IEI

, Block Ports
sroup: Computers
Part No Port Type Filter Type

~ [Blocked | [ add

Port No Port Type Filter Type

30 HTTP HTTP Filter

443 HTTPS HTTP Filter

2030 Proxy HTTP Filter

21 FTP Blocked

6881 Tarrents Blocked

I Remove ] I oK ] I Cancel J [ Apply J

Block ports will stop communication on specified network ports
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The Copy Group Settings function allows you to easily transfer the group settings from one group to

another group.

Source group: This is the group you want to copy the group settings from.
Settings to Copy: The detail of the group settings that you want to copy.
Destination Group: This is the group(s) you want to copy the group settings to.

@.‘ Copy Group Settings @
__- Copy Group Settings
Copy settings from source group to destination group(s). Previous settings of the destination group(s) will be
overwritten
Source group: Settings to Copy: Destination Groups:
Groups | | Settings Groups o
:‘: Computers i @ Internet Settings o :‘: Cu:umputers A
IC5) Accounting 7 DA URL Filter [C1£3) Accounting 7
[T Marketing B ﬁlﬂ App Blocker O Marketing b
I 5ales % Elock Port Settings i sales
ICiFinance Exlf Download Filter ICiFinance
I Management r#Eypass Application I Management
=3 Operations =3 Operations
I MewGroup{1) - i MewGroup(1) i
Select all settings [] select all groups
Heln [ oK ] [ Cancel ] [ Copy

Copy the group settings from one group to another folder

www.CurrentWare.com

45



¢ 69 Current\Ware

12.0 BrowseControl Client Settings

The BrowseControl Client Settings can be found under the BrowseControl tab on the right hand side
of the CurrentWare Console.

The BrowseControl Client Settings contains two options:

Enable Internet Access when the CurrentWare Server is unavailable

Toggle the option to activate the Internet access when the CurrentWare Client is not
connected to the CurrentWare Server.

When the CurrentWare Server is unavailable, you can pick to allow the workstation to have
Full Internet access or apply the existing Allowed list and Block List.

Enable AppBlocker when the CurrentWare Server is unavailable

Toggle the option to activate the AppBlocker when the CurrentWare Client is not connected
to the CurrentWare Server.

ﬂﬂ' BrowseControl Client Settings @

BrowseControl Cl

ient Seftings

ULV Y O

Enable Internet access
i Allow full internet access
@ Apply the existing allowed list and blocked list

Enable AppElocker

Ok ] [ Cancel Apply

When the CurrentWare Server is not available, the CurrentWare clients
can access the Allowed and Blocked list from the local database.
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13.0 CurrentWare Server Manager

The default client port is 8991 and the default console port is 8990.
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The CurrentWare Server Manager is used to manage the administrative tasks of the CurrentWare
Server. To access the Server Manager, click on the Start Menu > Programs > CurrentWare >
CurrentWare Server Manager

13.1 Changing the CurrentWare Client and Console Port

Changes to the Client and Console ports may be required to establish the connections between the
CurrentWare server, clients and consoles. For example, if you are using a program that is already
utilizing the ports that CurrentWare uses, then you will need to change
do not modify the Client and Console ports.

the ports. Otherwise, please

P CurrentWare Server Manager

(=] & |mSa)

tWare Sewer Manager

ﬂ CurreQ

~ Ports Service

= administrative a.-.u.--'---w: rrer are Ser
Ll Uis LUNTENLyalne o

Compress Archive and Restore

Port Settings

Client Paort 2991

Console Part 2990

Cancel

ver, 4.0.0

CurrentWare Server Manager
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13.2 Stopping the CurrentWare Server Service

To stop the CurrentWare Server, under the Service tab, click on the button “Stop CurrentWare
Server”

P CurrentiWare Server Manager E [=] @

Currentiare Server Manager
Helps ko manage the administrative kasks af CorrentWare Server

W Compress Archive and Restare

Conkrol Service

Server Service Status:  Running

Click. this button to startfskop Currentiare Server service,

Skop CurrentiWare Server |

ver, 4.0.0 Ok

13.3 Compress the CurrentWare Database

It is recommended that database compression be performed on a regular basis.

To compress your CurrentWare database:

Make sure you have closed the CurrentWare Console.

2. Go to the Start menu > Programs > CurrentWare > CurrentWare Server
Manager

3. Under the Compress tab, click on the browse button and search for your
CurrentWare database. By default, the database is located under C:\Program
Files\CurrentWare\cwServer\CWNPFB.CWD .

4. Click on the Compress button to begin compressing your database.

13.4 Archive and Restore the CurrentWare Database

In order to maintain optimal database performance, it is recommended that the CurrentWare
database be archived on a regular database. Archiving the CurrentWare database will create a copy
of your existing database. However, all tracking data from the existing live database will be deleted.
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Note: archiving will create a copy of the current database. After the archiving process is completed,
the Internet tracking data for BrowseReporter will be deleted. All Computer and User data will be
maintained but the corresponding monitoring data will be removed.

To Archive your CurrentWare Database:

1. Under the Archive and Restore tab, click on the Archive button (Fig. 21).

2. A copy of your database will be created under C:\ Program
Files\CurrentWare\cwServer\Archive\

Restoring the database will put your current database back to the state it was prior to archiving. The
current database will be replaced with the archived database. It is advised that you archive your
current database before restoring to a previous database, should you need to retrieve the original
data.

Restoring an Archived Database:

1. Under the Archive and Restore tab, select the database that you want to
restore from the drop-down menu

2. Click on the Restore button to begin the process of restoring your archived
database.
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14.0 CurrentWare and Terminal Server

The CurrentWare Console is supported on a Windows Terminal Server.

The CurrentWare Console for a terminal server is compatible for up to 65 concurrent connections.
Beyond this maximum number of connection, some of the CurrentWare functionalities may not work
properly. It is advised that you do not have more than 65 users connected to the Terminal Server

simultaneously.

The terminal server license is based on a per-user basis. Only one CurrentWare client can be
installed on the terminal server computer.
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15.0 Licensing
CurrentWare Solutions are licensed on a per-computer basis for client management, while Terminal
Server clients are licensed on a per-user basis.

The evaluation copy of BrowseControl is functional on a maximum of 50 computers for 21 days.

15.1 Register your Permanent License key

After you have purchased BrowseControl, BrowseReporter, enPowerManager or AccessPatrol from
CurrentWare, you will receive an email from our licensing department containing your license key
information, which includes the following fields:

1. Organization’s Name
2. Number of Licenses

3. License key

To register your license key, follow the steps below

Launch the CurrentWare Console
Go to Help > Licensing
From the Solutions drop down box, select the Solution

Select the mode of license (computers or terminal server)

o K N e

Copy your Organization’s name, number of licenses and Activation Code
from the licensing email sent to you

Click on the Register Button
Your CurrentWare Console has now been registered.

8. Click on Next to manage the computers you want to apply the license keys to.
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15.2 License Management

The License Computers console allows the administrator to select the computers to assign the
CurrentWare license to. Depending on the installed status of your CurrentWare clients, the licensing
process can be automatic or manual.

Managing your CurrentWare Licenses

You will need to manage your CurrentWare Licenses if you have applied your license key before
installing your CurrentWare Clients.

1. After you install your CurrentWare Clients, launch your CurrentWare Console
Go to Help > Licensing

Fill in the fields for the Organization name, solution, mode of license, number of
licenses and license key

Click next

Now the License Computers window will appear. This is where you assign your
licenses to your computers. Click on the checkbox to assign a license key to
your computer

@ License Computers @

L |® License Computers

»! Please select the computer(s) and the respective solution{s) to apply the license(s) to

’ Managed Computers |:| BrowseControl DBrowseReporter |:] enPowerManager
| Computer 1 v
X nieneeed @ | | Computer 2
| Computer 3
| Computer 4
; Computer 5
; Computer 6
Computer 7
‘ Computer 8

[ Back ][ Cancel ][ Apply ][ Finish ]

Manage your CurrentWare Licenses
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15.3 Managing your Terminal Server Licenses

The CurrentWare Console is compatible with Windows Terminal Server. The terminal server
licensing is based on a per-user basis.

When the terminal server license is applied, only one CurrentWare client can be connected to the
CurrentWare Server. This CurrentWare client must be installed on the terminal server.

CurrentWare’s Terminal Server license is strictly for Windows 2003 and 2008 terminal server
operating systems. Do not use terminal server license for any other Windows operating system as
some of the functions will not be compatible on it.

Applying your Terminal Server Licenses

1. Launch your CurrentWare Console
Go to Help > Licensing

Fill in the fields for the Organization name, solution, mode of license, number of
licenses and license key. (For Mode of License select “Terminal Server”)

Click next
Now the License Computers window will appear.

Click on the checkbox to assign a license key to your Terminal Server
computer. For Terminal server license, you will only be able to assign one
license key to one terminal server.

7. Click on the Manage Users button on top right hand corner to assign your
licenses to your users.

8. You will only be able to assign the number of licenses to your Terminal Server
users based on the quantity on your license agreement.
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4 Choose users for terminal server

User [”] BrowseControl
Computer 1 A
Computer 2 ,
Computer 3 ’
Computer 4 [@] :
Computer 5
Computer 6 [¥] |

][ concel [ acply

Manage your CurrentWare Terminal Server Licenses
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16.0 Uninstall CurrentWare Server, Console and
Solutions

16.1 Uninstalling the CurrentWare Solutions

Launch your CurrentWare Console
If a solution is installed, you will see the uninstall option under the “Install” menu.

Select Install > Uninstall BrowseControl, or Uninstall BrowseReporter, or Uninstall
enPowerManager, or Uninstall AccessPatrol.

Click Yes to uninstall the Solution from your CurrentWare Console.

The CurrentWare Console will restart and the solution will be removed from the
Console.

Alternatively, a solution can be uninstalled form the Add/Remove Programs utility in the Control
Panel.

16.2 Uninstalling the CurrentWare Server and Console

The CurrentWare Console and Server can be removed from the Control Panel.

1. Before you uninstall the CurrentWare Server and Console, ensure that all of the
CurrentWare Solutions are uninstalled first.
Go to Start Menu and select Control Panel
Under Programs, Select Uninstall a Program.

Uninstall CurrentWare
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17.0 Uninstall CurrentWare Client

The CurrentWare Client can be uninstalled by two different methods:

e Uninstall CurrentWare Client from the Console
e Uninstall CurrentWare Client on the workstation by command line
e Uninstall CurrentWare Client on the workstation from the Client

Configuration Window

17.1 Uninstall CurrentWare Client from the Console

Follow the steps below to uninstall the CurrentWare Client remotely from the CurrentWare Console.

Launch the CurrentWare Console

2. Right click on the computer or the group of computers that you want to uninstall,
select Client Service > Uninstall

3. The client will proceed to uninstall
4. A reboot will be prompted. It is recommended to restart the computer.

Computers

Add Mew Group

Rename

O

Delete

Refresh Data to Clients

%

| + Client Service 3 |Q Stop i
Client Settings @  Uninstl |

0 E

Properties
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17.2 Uninstall CurrentWare Client on the workstation by
command line

Follow the steps below to uninstall the CurrentWare Client locally on the workstation by running a
command line.

You need to have your CurrentWare Client password in order to uninstall the CurrentWare Client by

Command line.

On your CurrentWare Client computer, go to start menu > run > type in the following (for Windows 7,
go to the run command box):

Cweclient —p Admin —u

*The word “Admin” in the command is the password field. Admin is the default CurrentWare Client
password. If you changed the CurrentWare Client password during the installation, please replace
Admin with your CurrentWare Client password.

17.3 Uninstall CurrentWare Client on the workstation from
the Client Configuration Window

Follow the steps below to uninstall the CurrentWare Client locally on the workstation from the
CurrentWare client configuration Window.

To bring up the CurrentWare client configuration Window, go to start menu > run > type in the
following (for Windows 7, go to the run command box):

Cwclient —=p Admin -v

*The word “Admin” in the command is the password field. Admin is the default CurrentWare Client
password. If you changed the CurrentWare Client password during the installation, please replace
Admin with your CurrentWare Client password.

In the CurrentWare Client Configuration Window, click on the General Settings tab. Click on the
Uninstall button to uninstall the CurrentWare client from your workstation.
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18.0 Technical Support

For technical support of CurrentWare, please contact us at info@currentware.com.
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19.0 Contacts

USA

CurrentWare (a division of Codework Inc.)

1623, Military Rd #556, Niagara Falls, NY 14304-1745, United States of America
Tel: 613-368-4300

Fax: 866-929-9808

Email: info@currentware.com

CANADA

CurrentWare (a division of Codework Inc.)
55 Hawktree Ridge, Ottawa, K2J 5N7, Canada
Tel: 613-368-4300

Fax: 866-929-9808

Email: info@currentware.com

EUROPE

Codework Limited

Lansdowne House, 85 Buxton Rd, Stockport, SK2 6LR, United Kingdom
Tel: +44-(0) 161 - 474 - 0444

Fax: +44-(0) 333 - 666 - 0998

Email: info@codework.com

ASIA

Codework Solutions Pvt Ltd,

‘Thapasya’, Infopark, Kakkanad, Kochi, Kerala, India — 682030
Tel: +91-484-4055678

Fax: +91-484-4061003

Email: info@codework.com

OTHER COUNTRIES

Please email info@currentware.com for the name of a local reseller in your country.
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